Composio - GMAIL connections are being expired – Incident details

All systems operational

GMAIL connections are being expired

Resolved
Operational
Started 24 days agoLasted about 9 hours

Affected

Composio Platform

Partial outage from 10:15 AM to 11:15 AM, Operational from 10:15 AM to 7:34 PM, Partial outage from 11:15 AM to 7:34 PM, Operational from 7:34 PM to 7:34 PM

v3 API

Operational from 10:15 AM to 7:34 PM

Tool Execution

Partial outage from 10:15 AM to 7:34 PM, Operational from 7:34 PM to 7:34 PM

Tool Router

Operational from 10:15 AM to 7:34 PM

Triggers

Partial outage from 10:15 AM to 7:34 PM, Operational from 7:34 PM to 7:34 PM

Webapp

Operational from 10:15 AM to 7:34 PM

Updates
  • Resolved
    Resolved

    We'll continue to monitor the issue, and it has been resolved.

  • Monitoring
    Monitoring

    We've implemented the fix and monitoring the connections.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We've observed that GMAIL connections are being expired prematurely, and are failing to refresh the tokens. We're investigating the root cause.