Composio - Issues with Google Auth – Incident details

All systems operational

Issues with Google Auth

Resolved
Degraded performance
Started about 1 month agoLasted about 21 hours

Affected

Third Party Auth

Degraded performance from 8:15 PM to 5:15 PM

Google Auth

Degraded performance from 8:15 PM to 5:15 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. All services from Google are now working as expected.

  • Identified
    Identified
    Google has temporarily restricted our default auth config. We're actively working with their team to resolve this issue. **What's Available Now** We've deployed new credentials for our google default apps so if you make new auth configs you can continue building, we know this is limiting but this is a first solution. These temporary credentials have some limitations, they don't support google's sensitive scopes which include actions like * Deleting emails * Accessing other contacts * Full Google Drive search (you have to manually give access to files) We're collaborating with Google to restore sensitive scope support as quickly as possible. Additionally, we are actively working on a solution to allow users to continue working without any disruption. For production environments, we strongly recommend using custom auth configurations. Users with custom auth are not experiencing any issues and have full scope access. Learn more: