Composio - Unscheduled downtime (18th April) – Incident details

All systems operational

Unscheduled downtime (18th April)

Resolved
Operational
Started 7 days agoLasted about 19 hours

Affected

Webapp

Major outage from 4:13 PM to 5:57 AM, Partial outage from 5:57 AM to 6:54 AM, Degraded performance from 6:54 AM to 10:59 AM

v1/v2 API

Major outage from 4:13 PM to 5:57 AM, Partial outage from 5:57 AM to 6:54 AM, Degraded performance from 6:54 AM to 10:59 AM

v3 API

Major outage from 4:13 PM to 5:57 AM, Partial outage from 5:57 AM to 6:54 AM, Degraded performance from 6:54 AM to 10:59 AM

Tool Execution

Major outage from 4:13 PM to 5:57 AM, Partial outage from 5:57 AM to 6:54 AM, Degraded performance from 6:54 AM to 10:59 AM

MCP Server

Major outage from 4:13 PM to 5:57 AM, Partial outage from 5:57 AM to 6:54 AM, Degraded performance from 6:54 AM to 10:59 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    The fix is fully deployed across all services - we are noticing core functionality is back up and working but there is some degraded performance in certain apps with default auth i.e when you use Composio's Client id/ Client secret you might experience some degraded performance

    You might need to reconnect your account by reinitialising the connection

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.


    We are doing staged rollout, expect all services to be up relatively soon

  • Update
    Update

    we know it has been a few hours but team is hard at work through the night and we think we are almost ready to deploy a mitigation

    we expect to be live in the next 60-90 mins tops

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We are currently investigating this incident.