Composio - Degraded - Linear connection refresh – Incident details

All systems operational

Degraded - Linear connection refresh

Resolved
Degraded performance
Started 27 days agoLasted about 10 hours

Affected

Third Party Auth

Degraded performance from 9:42 AM to 7:19 PM

Linear Auth

Degraded performance from 9:42 AM to 7:19 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Auth refresh for Linear was being rate limited by Linear, it was resolved after increasing the refresh window. End users who have multiple (more than 3-4) Linear Accounts connected with their agents may still see auth refresh failures.

  • Investigating
    Investigating

    We're seeing elevated failures with Linear Auth Refresh for Composio Managed Connections. Some tool calls on existing Linear connections may fail.
    We've traced this to rate-limiting on Linear's API and are following up with the Linear team. Other integrations are unaffected - we'll post updates here.