Composio - All outgoing webhook & trigger deliveries are facing an outage – Incident details

All systems operational

All outgoing webhook & trigger deliveries are facing an outage

Resolved
Major outage
Started 1 day agoLasted about 6 hours

Affected

Triggers

Major outage from 1:30 AM to 7:08 AM, Operational from 7:08 AM to 7:13 AM

Triggers V2

Major outage from 1:30 AM to 7:08 AM, Operational from 7:08 AM to 7:13 AM

Triggers V1

Major outage from 1:30 AM to 7:08 AM, Operational from 7:08 AM to 7:13 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We're seeing full recovery on delivery volumes.

  • Monitoring
    Monitoring

    We have implemented the configuration fix and monitoring

  • Identified
    Identified

    We've identified the root cause as a fall out of our mitigation towards the ongoing security incident. We had rotated internal secrets across multiple internal services but due to a misconfiguration in the delivery service, the inter-service communication between the trigger & delivery service is severed. We are working on restoring this ASAP.

  • Investigating
    Investigating

    We are aware about an ongoing incident affecting ALL webhook delivery from Composio platforms to customers. No webhooks/triggers are currently being delivered to customers.