Composio - Slack triggers are degraded – Incident details

All systems operational

Slack triggers are degraded

Resolved
Partial outage 50 %
Started 2 months agoLasted about 1 hour

Affected

Triggers

Partial outage from 2:04 PM to 3:20 PM

Triggers V2

Partial outage from 2:04 PM to 3:20 PM

Updates
  • Resolved
    UTC
    Resolved

    Slack triggers should now be back up again! We're now seeing near full recovery for slack triggers as slack systems come back online: https://slack-status.com/2026-05/fe557ca05fdb64fa

  • Update
    UTC
    Update

    Slack's systems are still degraded (https://slack-status.com/2026-05/fe557ca05fdb64fa). But, we are seeing some early signs of recovery on slack's end, the ingress volume is still unstable and fluctuating rapidly. Webhook deliveries may be delayed or missed. We are closely monitoring the situation.

  • Monitoring
    UTC
    Monitoring

    We have confirmed that our systems are operational, but we are experiencing issues on slack events ingress due to an ongoing slack outage: https://slack-status.com/2026-05/fe557ca05fdb64fa. We are closely monitoring the situation and will update as things progress on slack's end.

  • Investigating
    UTC
    Investigating

    We are currently investigating an incident impacting slack triggers on the platform