Composio - We've been alerted failures in polling triggers – Incident details

All systems operational

We've been alerted failures in polling triggers

Resolved
Operational
Started 25 days agoLasted about 1 hour

Affected

Composio Platform

Partial outage from 4:05 AM to 4:10 AM, Operational from 4:05 AM to 5:10 AM, Partial outage from 4:10 AM to 5:10 AM, Operational from 5:10 AM to 5:15 AM

v3 API

Operational from 4:05 AM to 5:15 AM

Tool Execution

Operational from 4:05 AM to 5:15 AM

Tool Router

Operational from 4:05 AM to 5:15 AM

Triggers

Partial outage from 4:05 AM to 5:10 AM, Operational from 5:10 AM to 5:15 AM

Webapp

Operational from 4:05 AM to 5:15 AM

Updates
  • Resolved
    Resolved

    We've the system in stable form. All polling triggers are operational, and addressed the backfill as well.

  • Monitoring
    Monitoring

    We've implemented and tested the code in non production environments. We've deployed the fixes in production and shall continue to monitor. No action is needed for failed polling triggers so far, all events get backfilled and processed as usual.

  • Identified
    Identified

    We have identified the root cause and are working on a fix.

  • Investigating
    Investigating

    We are currently investigating this incident associated with triggers. The impact is limited to polling triggers, webhook triggers are not impacted.